dropdown menu

EXTRA - ALT_DISK

alt_disk_copy:

Required filesets:
    bos.alt_disk_install.boot_images
    bos.alt_disk_install.rte
    bos.msg.en_US.alt_disk_install.rte

alt_disk_copy -d <hdisk to clone rootvg>             this will clone the rootvg to the specified disk
alt_disk_copy -e /etc/exclude.rootvg -d <hdisk>      this will use the exclude list during the cloning
alt_disk_copy -T -d <hdisk>                          it will convert jfs to jfs2 on the new target disk (from 6.1 TL4 only)
alt_rootvg_op -X <cloned rootvg to destroy>          this will destroy the cloned rootvg (alt_rootvg_op -X altinst_rootvg)
alt_rootvg_op -W -d <hdisk>                          this will wake up a disk (cloned filesystems will be mounted with prefix /alt_)
alt_rootvg_op -S -t <hdisk>                          this will put cloned rootvg to sleep (before that it will do a bosboot)
                                                     (-S: put to sleep earlier "waked up" vg, -t: rebuilds the alt. bootimage before sleep)
alt_rootvg_op -v <new cloned rootvg name> -d <hdisk> this will rename the given cloned rootvg name
                                                     (after wake-up and sleep the cloned vg name will be changed, in this case it is useful)

alt_disk_mksysb -m /mnt/aix1mksysb -d hdisk1 -k      this will resore given mksysb (aix1mksysb) to hdisk1 (-k: keep device configuration)

/var/adm/ras/alt_disk_inst.log                       alt_disk log file
----------------------------------

alt_disk_copy: (copy hdisk0 to hdsik1)
lv names can't be longer than 11 characters (because of alt_ prefix)
do not take out that disk which was used during boot (otherwise there will be problems with bosboot)

-unmirrorvg rootvg hdisk1   
-reducevg rootvg hdisk1       
-bosboot -ad hdisk0       
-bootlist -m normal hdisk0   
-alt_disk_copy -d hdisk1       
-bootlist -m normal hdisk0

after booting from hdisk1:
root@aix11: / # lspv
hdisk0          00cf5d8fe9c88a34                    old_rootvg
hdisk1          00cf5d8fadcaa9a9                    rootvg          active


booting from the old disk:
root@aix11: / # lspv
hdisk0          00cf5d8fe9c88a34                    rootvg          active
hdisk1          00cf5d8fadcaa9a9                    altinst_rootvg


removing the new image (keeping the old one):
-alt_rootvg_op -X altinst_rootvg         <--removing the new image from hdisk1
-chpv -c hdisk1                          <--clear that pv what contained the removed image
-extendvg -f rootvg hdisk1               <--extend the currently used rootvg with the cleared disk (hdisk1)
-mirrorvg -S rootvg hdisk1               <--mirroring rootvg to hdisk1 (checking: lsvg rootvg | grep STALE)(-S: -background sync)
-bosboot -ad hdisk0; bosboot -ad hdisk1  <--recreate the bootimage
-bootlist -m normal hdisk0 hdisk1        <--setup correct bootlist (checking: bootlist -m normal -o)

------------------------------------

Changing lv names (to avoid 11 characters problem):
1. # mkszfile                            <--creates image.data file of rootvg
2. # vi image.data                       <--edit image.data
3. # alt_disk_copy -d hdiskX -i /image.data -B    <--give image.data fie for alt_disk_copy


--------------------------------------

ONLINE UPDATE WITH ALT_DISK_INSTALL:

unmirrorvg rootvg hdisk1                 <--removing mirror ( check: lsvg -p rootvg)
chpv -c hdisk1                           <--clears boot record
reducevg rootvg hdisk1                   <--free up hdisk1
bosboot -ad hdisk0                       <--creates boot record
bootlist -m normal hdisk0                <--sets boot list (check: bootlist -m normal -o)

installp -s                              <--check if anything can be commited
copy new bos.rte.install                 <--will be needed for checking if update will be successful (cd to this directory)
install_all_updates -pYd .               <--preview of new bos.rte.install
install_all_updates -Yd .                <--installs new bos.rte.install

oslevel -sg 5300-09-01-0847              <--shows which fileset is greater than current service pack, it will show bos.rte.install
instfix -i | grep SP                     <--it will show where to update (53-09-020849_SP)
oslevel -sl 53-09-020849                 <--shows which filesets should be update

cd /mnt/5300-09-SP2                      <--go to servicepack dir
install_all_updates -pYd .               <--preview check

alt_disk_copy -d hdisk1 -b update_all -l /mnt/5300-09-SP2     <--this will do the update

shutdown -Fr                             <--new OS will boot up
smitty commit                            <--if needed

alt_rootvg_op -X old_rootvg              <--removes cloned old OS
chpv -c hdisk0                           <--clears bootrecord
extendvg -f rootvg hdisk0                <--add hdisk0 to rootvg
mirrorvg -S rootvg hdisk0                <--mirror rootvg (-S: in background)
bosboot -a                               <--creates boot record
bootlist -m normal hdisk0 hdisk1         <--set bootlist

--------------------------------------

alt_disk error during AIX update:

If you see this:
...
...
install_all_updates: Result = SUCCESS
Modifying ODM on cloned disk.
Building boot image on cloned disk.

0301-150 bosboot: Invalid or no boot device specified!
usage:  bosboot {-a | -v} [-d device] [-p proto] [-k kernel] [-l lvdev]
                [-b file] [-M primary|standby|both] [-D|-I] [-LTq]
        Where:
        -a              Create boot image and write to device or file.
        -v              Verify, but do not build boot image.
        -d device       Device for which to create the boot image.
        -p proto        Use given proto file for RAM disk file system.
        -k kernel       Use given kernel file for boot image.
        -l lvdev        Target boot logical volume for boot image.
        -b file         Use given file name for boot image name.
        -D              Load kernel debugger.
        -I              Load and Invoke kernel debugger.
        -M primary|standby|both Boot mode - primary or standby.
        -T platform     Specifies the hardware platform type.
        -q              Query disk space required to create boot image.
        -L              Enable MP locks instrumentation.
0505-120 alt_disk_install: Error running bosboot in the cloned
root volume group.
Cleaning up.
forced unmount of /alt_inst/var/adm/ras/livedump
forced unmount of /alt_inst/var/adm/ras/livedump
...
...


There is a bug in alt_disk fileset in different 6.1 TL levels (for example in TL6).
Solution is to update alt_disk filesets separately before doing AIX update

1. I use these files, and copy them to a separate directory:
-rwxrwxrwx    1 root     nobody     28393472 Mar 05 13:36 bos.alt_disk_install.boot_images.6.1.9.30.U
-rwxrwxrwx    1 root     nobody       709632 Mar 05 13:35 bos.alt_disk_install.rte.6.1.9.30.U

2. update filesets with smitty update_all or install_all_updates -cYd /mnt/bb/alt_disk

3. try again AIX update: alt_disk_copy -d hdiskX -n -b update_all -l /mnt/AIX_new_level
--------------------------------------

60 comments:

Anonymous said...

Hi,

In alt_disk_copy and alt_disk_install, whether actual update will happen in normal hdisk0 (rootvg) or cloned hdisk1 (alt_inst_rootvg)

aix said...

Hi, it will happen on the cloned disk.

Anonymous said...

Hi,

In our environment we are doing TL upgrade for many servers daily.So our manager asked us to automate the alt_disk_copy.is it possible to write a script for alt_disk_copy?if so could you please give me some suggestions or websites for scripting.

Thanks in advance.Waiting for your valuable reply

aix said...

Hi, for ksh scripting, I would suggest this: http://www.bolthole.com/solaris/ksh.html

Mohammed Ismath basha said...

Hi i am getting below error while executing alt_clone

:root:/>alt_disk_copy -d hdisk1 -B
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
0505-102 alt_disk_install: mkvg has returned an error.
0516-058 /usr/sbin/varyonvg: Not enough memory available now. Try again later
0516-862 /usr/sbin/mkvg: Unable to create volume group.

aix said...

It says "Not enough memory..." Did you check load/RAM usage on the system?

Anonymous said...

Is it possible to find the oslevel in the updated disk before rebooting the server from the updated disk(after doing online update alt_disk_copy)

aix said...

I'm not aware of any of that.

Anonymous said...

np.Thanks,I'm just looking for it.

Anonymous said...

is it possible to upgrade TL on mirrored disk

abbas said...

Hi AIX

after creating the alt_clone i am unable to boot up with hdisk1(alt_clone disk) its throw the error like /usr/init/ i have search with some forum they told to disable the TCB, once i disabled i am able to create the alt_clone.its happened few servers only. could you plz tel me root cause for that..

Thanks

aix said...

yes, the section "ONLINE UPDATE WITH ALT_DISK_INSTALL" is describing that.

aix said...

Hi abbas,
I tried to find some info about it, and at IBM site on this is written: http://www-01.ibm.com/support/docview.wss?uid=isg1IV22448
I think you should open an IBM call and ask them about the root cause.

abbas said...

Hi AIX,

Thanks for your response ,yes i finally i had raised the case any once i got the root cause i will share

Thanks

abbas said...

Hi Aix ,

I need some suggestion from you , i have send the logs to IBM.meanwhile in all the server we disable and take the alt_clone means alt_clone disk working or not (could you please tel the concept for TCB availability in AIX)

aix said...

Because in our environment we don't use that, I can only show you some IBM links...but you can google them as well.

Bala said...

Hi ,

I am having 3 disks in rootvg and i am doing cloning rootvg using alternate disk installation from nim server . I am giving target disk as one disk ...size of the target disk is equal to size of the 3 disks in rootvg .

So my doubt is can we do cloning rootvg using alternate disk installation from nim server with rootvg having 3 disks ...since i have done only for rootvg with one disk ?

aix said...

Hi, I think you should test it, if there is a possibility on a test system. The other side, you cannot do anything wrong, the worst thing that your alt_disk copy cannot clone the system. If this happens, you can remove mirroring (so there is only 1 copy) temporarily, do the alt_disk and after reestablish the mirroring.

Bala said...

i tried it ...it worked fine but i took more time ..so rootvg can have 1 or more disk we can do altdisk to one disk .

aix said...

good, thanks for the feeback

abbas said...

Hi , last week i had been faced biggest issue in our production environment, i thought you had remember my previous query regarding the TCB (unable to took the Alt_clone while TCb in enabled status). while executing the tcbck -n ALL command its show some error like "TCB Attribute Error" finally IBM suggest to eliminate the error to run the tcbck -y ALL. but unfortunately while executed the command all ssh and Console session wiped out. servers was not letting users to login. could you please give some suggestion about (tcbck -y All). more people suffered for my worst actions for production environment down more than 8 hours. excepting your valuable inputs .

Thanks

aix said...

Hi, your comment is really valuable, thank you for sharing it with others. I would really help you, but we don't use TCB in our environment. How did you solve this major situation in production environment?

abbas said...

Hi Aix,
its ok , if you get anything about TCB in future means please share , ok come to our part finally we had raised the case with IBM but they tried more typical things in ODM no success, so they to told rebuild the server, grace of Almighty we have the NIM server so just restore from NIM server(NIM Server backup has scheduled in cron). for your reference "tcbck -n ALL" command shows the TCB attribute error, if its show like that means you should disable the TCB through ODM command then proceed the Alt_clone. ( Server was Rebuild-ed but my image was gone for my worst knowledge if god will need to rebuild that too):)

aix said...

Hi, thanks again... I think from your story every system administrator can learn something and I think you did your best :-)

Anonymous said...

Hi alt_root-vg_ not creating alt_disk_rootvg on hdisk1 .
hdisk1 is not a part of any VG .
I did this to create alt_disk , not working .
$ alt_root_vg -target hdisk1
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5.
Creating logical volume alt_hd6.
Creating logical volume alt_paging00.
Creating logical volume alt_hd8.
Creating logical volume alt_hd4.
Creating logical volume alt_hd2.
Creating logical volume alt_hd9var.
Creating logical volume alt_hd3.
Creating logical volume alt_hd1.
Creating logical volume alt_hd10opt.
Creating logical volume alt_hd11admin.
Creating logical volume alt_livedump.
Creating logical volume alt_lg_dumplv.
Creating /alt_inst/ file system.
Creating /alt_inst/admin file system.
Creating /alt_inst/home file system.
Creating /alt_inst/opt file system.
Creating /alt_inst/tmp file system.
Creating /alt_inst/usr file system.
Creating /alt_inst/var file system.
Creating /alt_inst/var/adm/ras/livedump file system.
Generating a list of files
for backup and restore into the alternate file system...
Backing-up the rootvg files and restoring them to the alternate file system...
Cleaning up.
forced unmount of /alt_inst/var/adm/ras/livedump
forced unmount of /alt_inst/var/adm/ras/livedump
forced unmount of /alt_inst/var
forced unmount of /alt_inst/var
forced unmount of /alt_inst/usr
forced unmount of /alt_inst/usr
forced unmount of /alt_inst/tmp
forced unmount of /alt_inst/tmp
forced unmount of /alt_inst/opt
forced unmount of /alt_inst/opt
forced unmount of /alt_inst/home
forced unmount of /alt_inst/home
forced unmount of /alt_inst/admin
forced unmount of /alt_inst/admin
forced unmount of /alt_inst
forced unmount of /alt_inst
$ lspv
NAME PVID VG STATUS
hdisk0 00c53aadf39fdfc5 rootvg active
hdisk1 00c53aad3ef393ed None

Anonymous said...

try alt_disk_install -C -B target_disk

Anonymous said...

Can i do alt_disk_install with efix availble in the current system or do i need to remove the efix before i clone or update the system with the alt_Disk?

aix said...

No efix removal needed...if your AIX level is not older than 2-3 years.

Anonymous said...

Wake up alt rootvg:
# alt_rootvg_op -W -d (hdiskx)
Check oslevel
# INUCLIENTS=1 chroot /alt_inst /usr/bin/oslevel -s
Put back to sleep writing boot record
# alt_rootvg_op -S -t

aix said...

Thanks a lot, that is really valuable :-)

Anonymous said...

Hi,

I am trying to restore mksysb on alternate disk using alt_disk_mksysb but it gives error, below snap. original mksysb was mirrored so i did copies= 1 and PP= same as LP= and then tried to restore mksysb on single disk but it gives error.

mksysb oslevel is 6100-06-06-1140
installed oslevel on server also same i.e 6100-06-06-1140

# alt_disk_mksysb -m /mksysb/abc.mksysb -i /tmp/vijay/image.data -d hdisk1 -O
Restoring /image.data from mksysb image.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5.
Creating logical volume alt_hd6.
Creating logical volume alt_hd8.
Creating logical volume alt_hd4.
Creating logical volume alt_hd2.
Creating logical volume alt_hd9var.
Creating logical volume alt_hd3.
Creating logical volume alt_hd10opt.
Creating logical volume alt_hd11admin.
Creating logical volume alt_dump01.
Creating logical volume alt_livedump.
Creating logical volume alt_mksysblv.
Creating logical volume alt_locallv.
Creating /alt_inst/ file system.
/alt_inst filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/admin file system.
/alt_inst/admin filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/mksysb file system.
/alt_inst/mksysb filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/opt file system.
/alt_inst/opt filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/tmp file system.
/alt_inst/tmp filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/usr file system.
/alt_inst/usr filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/usr/local file system.
/alt_inst/usr/local filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var file system.
/alt_inst/var filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var/adm/ras/livedump file system.
/alt_inst/var/adm/ras/livedump filesystem not converted.
Small inode extents are already enabled.
Restoring mksysb image to alternate disk(s).
Please mount volume 2 on /mksysb/abc.mksysb... and press Enter to continue
0505-149 alt_disk_install: WARNING: an error occurred during restore.
0505-121 alt_disk_install: Error.
Cleaning up.
forced unmount of /alt_inst/var/adm/ras/livedump
forced unmount of /alt_inst/var/adm/ras/livedump
forced unmount of /alt_inst/var
forced unmount of /alt_inst/var
forced unmount of /alt_inst/usr/local
forced unmount of /alt_inst/usr/local
forced unmount of /alt_inst/usr
forced unmount of /alt_inst/usr
forced unmount of /alt_inst/tmp
forced unmount of /alt_inst/tmp
forced unmount of /alt_inst/opt
forced unmount of /alt_inst/opt
forced unmount of /alt_inst/mksysb
forced unmount of /alt_inst/mksysb
forced unmount of /alt_inst/admin
forced unmount of /alt_inst/admin
forced unmount of /alt_inst
forced unmount of /alt_inst

Anonymous said...

Here is the issue found in your output "Please mount volume 2 on /mksysb/abc.mksysb... and press Enter to continue"

What is the size of your mksysb? and the size of hdisk1?
Also, please confirm if you have a good copy of mksysb? (using lsmksysb -lf command)
I suggest you to take a new mksysb,...... use -p flag and take a new mksysb... Now, the mksysb will be run fully and will not skip any binary files which are in larger size.

Anonymous said...

Hi
I'm having this issue while creating altinst_rootvg.

/usr/sbin/alt_disk_copy -B -d hdisk0
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5.
Creating logical volume alt_hd6.
Creating logical volume alt_hd8.
Creating logical volume alt_hd4.
Creating logical volume alt_hd2.
Creating logical volume alt_hd9var.
Creating logical volume alt_hd3.
Creating logical volume alt_hd1.
Creating logical volume alt_hd10opt.
Creating logical volume alt_hd11admin.
Creating logical volume alt_livedump.
Creating logical volume alt_fslv00.
Creating logical volume alt_corefiles.
Creating logical volume alt_lv_tsmbin.
Creating logical volume alt_srmlv.
Creating logical volume alt_ecclv.
Creating logical volume alt_mksysbfs.
Creating logical volume alt_hd7.
Creating logical volume alt_fslv01.
Creating /alt_inst/ file system.
/alt_inst filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/admin file system.
/alt_inst/admin filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/audit file system.
/alt_inst/audit filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/home file system.
/alt_inst/home filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/mksysbfs file system.
/alt_inst/mksysbfs filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/opt file system.
/alt_inst/opt filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/opt/core file system.
/alt_inst/opt/core filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/tmp file system.
/alt_inst/tmp filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/usr file system.
/alt_inst/usr filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/usr/ecc file system.
/alt_inst/usr/ecc filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/usr/tivoli file system.
/alt_inst/usr/tivoli filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var file system.
/alt_inst/var filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var/adm/ras/livedump file system.
/alt_inst/var/adm/ras/livedump filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var/perf/pm file system.
/alt_inst/var/perf/pm filesystem not converted.
Small inode extents are already enabled.
Creating /alt_inst/var/perf/pm/ file system.
0505-104 alt_disk_install: crfs failed to create file system /alt_inst/var/perf/pm/.
crfs: /alt_inst/var/perf/pm file system already exists

Cleaning up.

Gurpreet said...

Hi, Is there any way to apply update and ifix in one go using alt_disk_install. I actually have to update my system from tl1 to tl3 and at the same apply an IFIX.
Could you please suggest how to do so?

Thanks!
ABC

Yakub Humami said...
This comment has been removed by the author.
Anonymous said...

Hi Experts,

I am getting the below error while I am trying to upgrade AIX7.1 to latest TL level

EFIX MANAGER LOCKS
------------------

* * * ATTENTION * * *

The following selected filesets are locked by EFIX manager:

openssl.base

installp has halted this operation because one or more files in the
filesets listed above are registered as having an EFIX. You must remove
these EFIXES before performing operations on the given fileset.

To get a listing of all locked filesets and the locking EFIX label,
execute the following command:

# /usr/sbin/emgr -P

To remove the given EFIX, execute the following command:

# /usr/sbin/emgr -r -L

For more information on EFIX management please see the emgr man page
and documentation.

install_all_updates: Log file is /var/adm/ras/install_all_updates.log
install_all_updates: Result = FAILURE
alt_rootvg_op: 0505-224 ATTENTION: An error occurred during installation of
one or more software components.


I guess I have to remove the efix before proceeding further. can you please help me in removing efix off the altdisk_rootvg?

Anonymous said...

hello
I'm refering to/commenting on the section "Changing lv names (to avoid 11 characters problem)", used on an AIX5.3 :
after changing the names in image.data and rebooting on the alt disk I also had to modify /etc/filesystems to allow mouting of all FS on modified LV.
the LV names were not modified in there during the alt_disk_copy process.

aix said...

Hello, thanks, good point :)

Misbah said...

Iam getting the below error when i try to clone the mirrored rootvg. i did not break the mirror.

alt_disk_copy -Bd hdisk2
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5
0516-404 allocp: This system cannot fulfill the allocation request.
There are not enough free partitions or not enough physical volumes
to keep strictness and satisfy allocation requests. The command
should be retried with different allocation characteristics.
0516-822 mklv: Unable to create logical volume.
0505-115 alt_disk_install: mklv failed to create logical volume hd5.
Cleaning up.

Nawe said...

Your page is the best page of quick sheets for AIX! If you know what you want to do but you don't remember some step or command, this is the best place to go! Keep the good work!

aix said...

Thanks, that was exactly the original reason why I created this blog :)

Manoj Suyal said...
This comment has been removed by the author.
Manoj Suyal said...

Hi Balazs,

My system rebooted while the clone disk was in wake up stage (all filesystem were mounted including clone disk), now system is hung in 554 !

Can this be recovered ?

Early help would be appreciated !

Regards
Manoj

Anonymous said...

I'm having issues finding the log file that shows the alt_disk_install completed. I have checked every file under /var/adm/ras but all have dates from weeks even months ago. I went through smitty nim -> Perform NIM Software Installation and Maintenance Tasks -> Alternate Disk Installation -> Clone the rootvg to an Alternate Disk. I went from AIX 7.1 TL 2 to AIX 7.1 TL4.

aix said...

Smitty has its own log file, under the home directory of the user invoked smitty: $HOME/smit.log

Anonymous said...

Hi aix, thanks for the reply. I'm familiar with everything being logged to that users home DIR, in my case root when you use the smitty menus. There is information in there for me going through the smitty menus but I do not believe it logs the actual activity, at least mine didn't for the alt_disk_install process.

aix said...

Hmmm....are you searching for logs on the NIM server or on the NIM client?

Anonymous said...

Good morning aix. I have looked at both but just under the normal path, /var/adm/ras. I'm not sure if it would go anywhere else. These are inherited system from an admin no longer employed here so I ask her as I am sure she knows. The system does perform the upgrade but I just can't understand why no log file. Permissions seems to be fine and I can read/write to that DIR. It's not an entirely BIG deal as this upgrade is in lieu of a hardware refresh coming up sometime in Jan. and we are moving off of these P5 to P8 so I'm excited about that, and don't want to spend too much time on this. I do appreciate the assistance from this group and thanks, aix for the suggestions.

Anonymous said...

Hello AIX Admins,

I am migrating from AIX 7.1 to 7.2 using nimadm on alt_disk.
I have included some efixes as per this document.. http://www-01.ibm.com/support/docview.wss?uid=isg3T1012104
But my migration is not installing the ifix , any suggestions ?

aix said...

I have no idea, probably if you send details to IBM in a PMR they can analyze it.

This workaround from the same link should also help I guess:
To install an ifix into an altinst_rootvg that has already been created, you first perform a wake-up operation on the altinst_rootvg: # alt_rootvg_op -Wd hdisk#

Then, you can install the ifix: # alt_rootvg_op -Cw IZ12345.epkg.Z -l /ifix_dir

It is extremely important to put the altinst_rootvg back to sleep after the ifix has been installed: # alt_rootvg_op -S

Unknown said...

hi recently i've migrated OS from 6.1 to 7.1 .The migration was successful on client.while rebooting with cloned disk it always went to sms menu .please suggest

Anonymous said...

Hi, this is very nice post, thanks !
I have one query, can we simulate preview mode for packages to install on alt-disk? I see that there are installp options which can be provided with alt_disk_copy command with -I flag, can I use -p flag for preview mode here? any other way?

Anonymous said...

Do you know how to migrate a alternate disk already created to a new one. I mean, the alternate disk is located in one lun, now I need migrate these lun to a new one because the old storage will be sunset.

Anonymous said...

in my altclone vg the PP size compare to rootvg is half also no errors in any log file
Please help me to know my alt_clone_vg is success

Anonymous said...

in my altclone vg the PP size compare to rootvg is half also no errors in any log file
Please help me to know my alt_clone_vg is success

Anonymous said...

Hi AIX

odi*****# alt_disk_install -C hdisk1
+-----------------------------------------------------------------------------+
ATTENTION: calling new module /usr/sbin/alt_disk_copy. Please see the alt_disk_copy man page
and documentation for more details.
Executing command: {/usr/sbin/alt_disk_copy -d "hdisk1"}
+-----------------------------------------------------------------------------+
Calling mkszfile to create new /image.data file.
Checking disk sizes.
Creating cloned rootvg volume group and associated logical volumes.
Creating logical volume alt_hd5
Creating logical volume alt_lg_dumplv
Creating logical volume alt_hd6
Creating logical volume alt_sec_dumplv
Creating logical volume alt_hd8
Creating logical volume alt_hd4
Creating logical volume alt_hd2
Creating logical volume alt_hd9var
Creating logical volume alt_hd3
Creating logical volume alt_hd10opt
Creating logical volume alt_fslv02
Creating logical volume alt_log4cust
Creating logical volume alt_lv_clocal
Creating logical volume alt_lv_global
Creating logical volume alt_lv_system
Creating logical volume alt_lv_4_usrecc
Creating logical volume alt_lv_avamar
Creating /alt_inst/ file system.
Creating /alt_inst/clocal file system.
Creating /alt_inst/cust file system.
Creating /alt_inst/global file system.
Creating /alt_inst/opt file system.
Creating /alt_inst/system file system.
Creating /alt_inst/tmp file system.
Creating /alt_inst/usr file system.
Creating /alt_inst/usr/ecc file system.
Creating /alt_inst/usr/local/avamar file system.
Creating /alt_inst/var file system.
Generating a list of files
for backup and restore into the alternate file system...
Backing-up the rootvg files and restoring them to the
alternate file system...



While taking clone , it was hung at above o/p can you help me on this.

aix said...

You can check with "df" command in another session how it progreeses (which filesystem usage is increasing during copy).

jana said...

[:root:/home/root:] lspv
hdisk0 00cf838c0bdc09b1 old_rootvg
hdisk1 00cf838c0bdc1099 swapvg active
hdisk2 00cf3d0a4c008214 old_rootvg
hdisk3 00cf3d0a4eee9720 rootvg active
[:root:/home/root:] alt_rootvg_op -v rootvg_7 -d hdisk2
[:root:/home/root:] lspv
hdisk0 00cf838c0bdc09b1 None
hdisk1 00cf838c0bdc1099 swapvg active
hdisk2 00cf3d0a4c008214 rootvg_7
hdisk3 00cf3d0a4eee9720 rootvg active
[:root:/home/root:] alt_rootvg_op -v old_rootvg -d hdisk0
[:root:/home/root:] lspv
hdisk0 00cf838c0bdc09b1 old_rootvg
hdisk1 00cf838c0bdc1099 swapvg active
hdisk2 00cf3d0a4c008214 rootvg_7
hdisk3 00cf3d0a4eee9720 rootvg active
[:root:/home/root:]

I had created an aix 6.1 and then cloned to another disk and migrated that disk to 7.1 and cloned the 7.1 disk to another disk, which created two old_rootvg, just because the name was same, both belonged to the same vg.
SO the above experiment was carried out.

aix said...

Thx for letting us know.

Anonymous said...

I am also facing same issue please provide the solution