dropdown menu

STORAGE - SDDPCM

SDDPCM:

SDDPCM is a loadable path control module designed to support the multipath configuration environment in the IBM TotalStorage Enterprise Storage Server, the IBM System Storage SAN Volume Controller, and the IBM TotalStorage DS family.

When the supported devices are configured as MPIO-capable devices, SDDPCM is loaded and becomes part of the AIX MPIO FCP (Fibre Channel Protocol) device driver. The AIX MPIO device driver with the SDDPCM module enhances the data availability and I/O load balancing.

You cannot install SDD and SDDPCM together on a server. When supported storage devices are configured as non-MPIO capable devices (that is, multiple logical device instances are created for a physical LUN), you should install SDD to get multipath support. Where only one logical device instance is created for a physical LUN you must install SDDPCM.

SDDPCM server daemon:
SDDPCM has a server daemon running in the background: lssrc/stopsrc/startsrc -s pcmsrv
psmsrv provides path-recovery function for SDDPCM devices

these module added to the kernel: sddpcmke, sdduserke


pcmpath
pcmpath query adapter            shows adapter configuration
pcmpath query version            shows the version of the sddpcm
pcmpath query device             shows the sddpcm devices (pcmpath query device 44 <--shows only this device)
pcmpath query essmap             good overview

pcmpath set device algorithm     dynamically change the path selection algorithm
pcmpath set device hc_mode       dynamically chane the path health check mode
pcmpath set device hc_interval   dynamically change the path healthcheck time interval

pcmpath set device M  path N online/offline dynamically enable (online) or disable (offline) a path
pcmpath set adapter N online/offline dynamically enable (online) or disable (offline) an adapter
                                 (SDDPCM resereves the last path of a device, it will fail if the device is using the last path)

pcmquerypr                        reads and clear persisten reserve and registration keys
pcmquerypr -vh /dev/hdisk30       to query and display the persistent reservation (-V verbose mode, more details)
pcmquerypr -rh /dev/hdisk30       release the persistent reservation if the device is reserved by the current host
pcmquerypr -ch /dev/hdisk30       remove the persistent reservation and clear all reservation key registration
pcmquerypr -ph /dev/hdisk30       remove the persistent reservation if the device is reserved by the other host

pcmgenprkey                       set or clear the PR_key_value ODM attribute for all SDDPCM MPIO devices

pcmpath query device | egrep "^DEV|^SERIAL" | paste - - | awk '{print $5 "\t" $12}' | sort -k1.6n  list hdisks + serial numb. (hdisk order)
------------------------------------

Change adapter settings (reconfigure paths):

1. If possible put the required adapter offline with the subsystem driver (pcmpath,dlnkmgr):
   (this will put into Disabled state)
    -pcmpath set adapter 3 offline
    -dlnkmgr offline -hba 08.07

2. Put all the Disabled path to Defined:
    -for i in `lspath | grep Dis | grep fscsiX| awk '{print$2}'`; do rmpath -l $i -p fscsiX; done

3. If there are other paths still in Enabled or Failed state put them into Defined:
    -rmpath -l hdisk9 -p fscsi1

4. Remove all devices from ODM from the mentioned adapter:
    -rmdev -Rl fcs2
    -lsdev -p fscsi2    <--should not show the disks

5. Change the adapter settings
    -chdev -l fscsi1 -a dyntrk=yes -a fc_err_recov=fast_fail
    -chdev -l fcs1 -a init_link=pt2pt

6. Config:
    -cfgmgr

1 comment:

UG said...

The safest and best way to remove a failed path in Production server is through Smitty.
Run --> Smitty mpio --> MPIO parent Management --> Path Management for a Parent --> Remove Path --> Remove Path Under a Parent -- > Parent Name ( fscsi0 or 1) select 1 in 1 go
Select all paths or select the failed path only.
Select Keep definition in DB as no.
Your failed paths will not be available anymore.
Check the path now by running command - datapath query adapter.
Now you r in good shape ... Enjoy