dropdown menu

EXTRA - MULTIBOS

MULTIBOS:

By default the BOS filesystems in rootvg (/, /usr, /var, /opt) and the BLV (hd5) are copied. All other filesystems and lvs are shared between BOS instances.

multibos -?                           <--gives info of the parameters

Multibos update:

lsvg rootvg | grep FREE               <--checking if we have enough free space in rootvg
multibos -R                           <--remove any standby BOS from earlier (-R: remove)
multibos -sXp                         <--preview the operation (-s:setup, -X:expand fs if needed, -p:preview)
alog -of/etc/multibos/logs/op.alog    <--shows the log file

multibos -sX                          <--creates standby BOS
lsvg -l rootvg | grep bos             <--bos prefix added to the new lvs and fs'

multibos -S                           <--start standby BOS shell (-S:shell operation)
oslevel -s                            <--checking standby BOS level
exit                                  <--leaving standby BOS shell

multibos -Xacp -l /mnt/TL9SP4         <--preview of the update of the standby BOS (-a:update all, -c:customization operation?)
multibos -Xac -l /mnt/TL9SP4          <--updates the standby BOS (when done check new OS level in "multibos -S" (after then exit))

bootlist -m normal -ov                <--check that bootlist is set to standby BOS (-v:verbose)
                                      Check the correct BLV. Compare the output from bootlist with “Welcome to AIX” banner at startup (HMC).
                                      (usually no action is needed, multibos automatically sets the new blv)
------------------------------------
e.g:
root@aix31: / # bootlist -m normal -ov
'ibm,max-boot-devices' = 0x5
NVRAM variable: (boot-device=/pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:4 /pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:2)
Path name: (/pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:4)    <--check this pathname at startup, to determine which blv is used
match_specific_info: ut=disk/scsi/scsd
hdisk0 blv=bos_hd5
Path name: (/pci@80000002000000c/pci@2/pci1069,b166@1/scsi@0/sd@4:2)    <--as you see the ony difference is the :4 vs :2)
match_specific_info: ut=disk/scsi/scsd
hdisk0 blv=hd5


root@aix31: / # bootlist -m normal -o
hdisk0 blv=bos_hd5
hdisk0 blv=hd5
------------------------------------

shutdown -Fr                   <--reboot
bootinfo -v                    <--verify which BLV the system booted from (bos_hd5 should be seen)
                               (the new fs' are now mounted and the old ones are renamed to bos_...)

if we need to go back to the original OS:
bootlist -m normal hdisk0 blv=hd5 hdisk0 blv=bos_hd5    <--set the bootlist to the original BLV first
shutdown -Fr


if you want to keep the upgraded OS (just without the bos_ prefixes):
(0. if you want you can remove the original OS: multibos -R)    <--this will remove the original lvs, which were not upgraded
1. multibos -sX                <--as we have already bos_ prefixes, it will create the lvs as the original ones: hd2, hd9var, hd5...)
2. shutdown -Fr                <--BLV will be set to hd5, so the otiginal lvs OS (upgraded) will be boot
3. multibos -R                 <--removes the bos_ enrties from rootvg

13 comments:

Gileb said...

Hi !
Nice blog, really helpful.
Multibos compared to alt_disk, raises a question...
The advantage of multibos compared to alt_disk is the fact it keeps both systems on the same disks... but, what if the upgraded os doesn't boot ? how to you go back on the old one ?

aix said...

Hi Gileb!

Thx :)
As the blv (hd5) is also copied during multibos creation, you can specify which one is used for booting.

During multibos creation you can see this:
+-----------------------------------------------------------------------------+
Logical Volumes
+-----------------------------------------------------------------------------+
Creating standby BOS logical volume bos_hd5
Creating standby BOS logical volume bos_hd4
...

Checking the bootlist after multibos command:
# bootlist -m normal –o
hdisk0 blv=bos_hd5
hdisk0 blv=hd5

Changing bootlist if desired:
# bootlist -m normal hdisk0 blv=hd5 hdisk0 blv=bos_hd5

Checking bootlist again:
# bootlist -m normal –o
hdisk0 blv=hd5
hdisk0 blv=bos_hd5

Hope this helps :)

Gileb said...

Ok thanks for your answer. But in order to execute thoses commands, you need to boot in service mode (via nim, mksysb or cdrom...), if you are not able to boot at all in contrast to alt_disk, where you just need to boot in sms mode, and choose the right disk, am i right ?

Anyway this is a nice feature, that can be really helpful, in some case.

aix said...

I did not test that, but I think you are right. And I agree this multibos can be really helpful if you have 1 disk only.

Jozef Riha said...

you can still boot from firmware OK menu. multibos actually gives you the parameter for boot command should you need it:
ATTENTION: firmware recovery string for standby BLV (hd5):
boot /vdevice/v-scsi@3000000b/disk@8100000000000000:2
ATTENTION: firmware recovery string for active BLV (bos_hd5):
boot /vdevice/v-scsi@3000000b/disk@8100000000000000:4

aix said...

good point :-)

Unknown said...

Hi - is there any way/direct command to find the multibos image (standby) is bootable?
I have a situation where the multibos image copy (standby copy) fails to boot and got struck at LED 0554

Anonymous said...

Please suggest me can I do multibos upgrade using CD.
Because in cd I din't find any TL.

Unknown said...

Hello.
If using multibos - what are the file systems are created

Anonymous said...

Hello, i dont know if you still need an answer. But here i am.

The filesystems that multibos copy are /, /usr, /var, and /opt. So if you want to use multibos, you should check that in rootvg you have enough space to duplicate that filesystems.

If you want to use multibos, and then install some efix, you should copy the efix, in some filesystem that multibos duplicate.

Anonymous said...

Hello, my multiboot, has not been able to to put initial bootlist. I have perform a bosboot -a -d on initial hd5 blv, but neither multibos -R, not multibos -S works.
How to perform a clean manual removal of standby multibos items ?

Anonymous said...

Hi All,
I have a questions :
1. Can we execute commands on Multibos from a script? , since executing the Multibos command from the script starts the multibos shell and it is in interactive mode, the script hangs here.
2. Is there silent/quite/non-interactive mode for multibos ?

Tushar said...

For e.g a shell scrip which will do below things on Multibos from active bos-filesystems-in-rootvg

mymachine # vi test.sh
#!/bin/sh

echo "In the script"
mutlibos -S
oslevel -s > afile.txt
exit
echo "In the script,exited Multibos shell"
echo "Done"