dropdown menu

EXTRA - OTHERS

+OTHERS:


CHECKSUM:

sum <file>            do a checksum using byte-by-byte algorithm (downloaded firmware or HMC update iso images need this)
csum -h SHA1 <file>   do a checksum using sha1 hash algorithm (HMC upgrade network install images need this)
csum -h MD5 <file>    do a checksum using md5 hash algorithm

------------------------------

EXTENDED HISTORY:

vi /etc/profile:

export EXTENDED_HISTORY=ON
alias history='fc -lt'

------------------------------

EXTENDED HISTORY SEPARATELY FOR EACH USER:


HISTSIZE = Maximum size of the history file
HISTFILE = Location/filename used to record commands executed.


vi /etc/profile:

### Secondary Logging Start ###
if tty >/dev/null 2>&1
then
  From="`/usr/bin/who am i | awk '{ print $1 }'`"
  To="`/usr/bin/whoami | awk '{ print $1 }'`"
  File="$From:$To:$(date +'%Y%m%d%H%M%S')"
  if [ ! -d /var/adm/history/$To ]
        then
        mkdir -p /var/adm/history/$To
        chmod 700 /var/adm/history/$To
  fi

  export HISTFILE=/var/adm/history/$To/.sh_history.$File
  export EXTENDED_HISTORY=ON
  export HISTSIZE=10000
  export HISTDATEFMT=%d-%m-%y.%H:%M:%S
### Secondary Logging End ###

------------------------------

PORTMIR:

man portmir
who am i
ps -ef|grep sshd
portmir -t /dev/pts/1
df -k
portmir -o

------------------------------

BLINKING AN HDISK:

1.diag
2.Task Selection
4.Hot Plug Task
5.SCSI and SCSI RAID Hot Plug Manager (or: SCSI Hot Swap Manager)
6.Identify a Device Attached to a SCSI Hot Swap Enclosure Device
(select the hdisk you want to identify)

If you can't find the hdisk by the code numbers:
diag
Diagnostic Routines
System Verification

This is the output:
 hdisk0           P2/Z1-A8             16 Bit SCSI Disk Drive (9100 MB)
 hdisk1           P2/Z1-A9             16 Bit SCSI Disk Drive (9100 MB)

------------------------------

AUDIT:

should be in inittab
the command: audit, will lists posiible parameters
audit start| shutdown

------------------------------

GPFS:

lsitab -a|grep mm
man mmshutdown
mmlscluster
ps -ef|grep mm
cd /var/adm/ras
ls -ltr|grep mm
more mmfs.log.latest
mmlsnsd
mmlscluster


------------------------------

RAMDISK:

root@aix21h27c: /etc # lsitab -a | grep ram
ramdisk:2:once:/etc/rc.ramd > /dev/console 2>&1 # Create ramdisk


root@aix21: /etc # cat rc.ramd
#!/usr/bin/ksh

/usr/sbin/rmramdisk /dev/rramdisk0
/usr/sbin/mkramdisk 400M

/usr/bin/echo yes | /sbin/helpers/jfs2/mkfs -V jfs2 -o log=INLINE /dev/ramdisk0
/usr/sbin/mount -V jfs2 -o log=/dev/ramdisk0,cio /dev/ramdisk0 /homes/P02/pci
...

------------------------------

ISO IMAGE CREATION:

mkdvd -r /directory -S        <--it will create image from the whole directory in /mkcd/cd_images filesystem (rename file to ...iso)
mkdvd -V rootvg -R -S         <--create an mksysb in an iso fromat from rootvg

After iso image has been removed from /mkcd/cd_images filesystem, this filesystem can be deleted.

 ------------------------------

ISO IMAGE MOUNTING (AIX 6.1 TL4):

# loopmount -i cdrom.iso -o "-V cdrfs -o ro" -m /mnt        <--mounts an iso image
(It creates a loopback device if not specified. If you give -l then you must specify a looback device name (loop0, loop1...)

# loopumount -l loop0 -m /mnt/dvd                           <--umounts an iso image and removes loopback device

An image file can be associated with only 1 loopback device.


1320-003 loopmount: Specified loopback device is not found in ODM

If no loopback devices are present on the system you must create one:

# lsdev -C | grep loop                                      <--checking for loopback device availability
# mkdev -c loopback -s node -t loopback                     <--createing a looback device

------------------------------

ISO IMAGE MOUNTING (AIX 5.3):
e.g. we have a file in /tmp called aix_5.iso which is 370MB

1. identify the nearest multiple of 128 MB that will provide enough space for the image. In this case it is 384MB
2. mklv -y cdlv -s n -L /dev/cdlv rootvg 384M hdisk0        <--create a logical volume with 384MB
(If the command fails, increase the volume size by a multiple of 128.)
3. dd if=/tmp/aix_5.iso of=/dev/cdlv                        <--copying the files in the ISO to disk
(This command may take a long time and will create two dd processes.)
4. mount -v cdrfs -o ro /dev/cdlv /mnt/iso                  <--mount the device like a CD-ROM

------------------------------


9 comments:

Anonymous said...

What is the difference between Managed system and frame

aix said...

IBM sometimes does not give clear meaning... I searched but could not find the real difference. In HMC I can see managed systems, but these can be referred to frames as well...

Unknown said...

Managed System is any system managed through HMC. like P6-595 Frame is also a system. Frame is term used when for example we have 5 p6-595 managed through HMC. and they are numbered from 1 to 5. So these are referred to Frame-1 , Frame 2 , and so on and term frame used when for example using LPM that particular lpar should be moved from Frame-1 to Frame-2 easy to follow and avoid confusion. This is how I understand and using in our environment.

aix said...

Thanks a lot...good explanation :)

Anonymous said...

Hi,

We have autosys installed on an AIX LPAR running with OSLEVEL : 6100-07-01-1141
We are having issues to bring up autosys on this now

error received:


# CCi daemon
$CAIGLBL0000/cci/bin/caiccid
+ /opt/autosys/CCISA/cci/bin/caiccid
exec(): 0509-036 Cannot load program /opt/autosys/CCISA/cci/bin/caiccid because
of the following errors:
0509-130 Symbol resolution failed for /opt/CA/CAlib/libenf.o because:
0509-136 Symbol caienfk (number 16) is not exported from
dependent module /unix.
0509-026 System error: Error 0
0509-192 Examine .loader section symbols with the
'dump -Tv' command.

Unknown said...

Historically, a frame was referenced when the SP2's were around. If you search for SP2, it will apparent why they were called frames. Inside the SP2 frame's, were physical nodes. A node could be thin, wide and high, all referring to the size of the node. All nodes were physically connected to each other and to the HMC. If your frame was full (of nodes) and you wanted to add more, you needed to buy another frame. You would physically connect the frames together to make a larger interconnected system. Hence its name - Scalable Power
Since around the eServer was introduced, which is now System P (and System I), IBM referenced them as managed machines.

aix said...

Thanks!

Unknown said...

I had a funny incident and thought it would help someone out there.

We booted a AIX7.1.3.4 on power8, with default power8 compatibility mode, and the server started showing some interesting errors with ssh.

- key_verify failed for server_host_key

- Bad packet length 1323175368.
Disconnecting: Packet corrupt

This happened be an issue with booting the server in power8 mode, and changing to compatibility mode to power7 and booting the server solved this issue.

Hope this helps
-Sunil Shivamallu

Unknown said...

Here is the technote from IBM

http://www-01.ibm.com/support/docview.wss?uid=isg1IV75570