Essentially the SPOT is a /usr filesystem just like the one on your NIM master. Everything that a machine requires in a /usr file system, such as the AIX kernel, executable commands, libraries, and applications are included in the SPOT. During client install client needs to run commands (mkvg, mklv..), these commands are availabe in the SPOT.
During the installation, the client machine NFS mounts this resource in order to access the code needed for the installation process. Device drivers, the BOS install program, and other necessary code needed to perform a base operating system installation are found inside the SPOT.
SPOT is responsible for
- Creating a boot image to send to the client machine over the network.
- Running the commands needed to install the NIM client.
You can think of it as having multiple "mini-systems" on your NIM master, because each SPOT is its own /usr filesystem. You can upgrade it, add fixes to it, use it to boot a client system....etc.
You can also create a SPOT from a NIM mksysb resource. This SPOT however is not as versatile as one created from an lpp_source and can not be upgraded with any fixes and can only be used with the mksysb resource it was created from.
When a SPOT is created, network boot images are constructed in the /tftpboot directory using code from the newly created SPOT. When a client performs a network boot, it uses tftp to obtain a boot image from the server. After the boot image is loaded into memory at the client, the SPOT is mounted in the client's RAM file system to provide all additional software support required to complete the operation.
root@aixnim1: / # lsnim -l spot_5300_09
spot_5300_09:
class = resources
type = spot
plat_defined = chrp
Rstate = ready for use
prev_state = ready for use
location = /nim/spot/spot_5300_09/usr <--shows the location
...
operations:
reset = reset an object's NIM state
cust = perform software customization
showres = show contents of a resource
maint = perform software maintenance
lslpp = list LPP information about an object
fix_query = perform queries on installed fixes
showlog = display a log in the NIM environment
check = check the status of a NIM object
lppchk = verify installed filesets
update_all = update all currently installed filesets
creating a SPOT (only the top directory should be specified, the SPOT directory will be created automatically):
nim -o define -t spot -a server=master -a location=/nim/spot -a source=5300-09-03 -a installp_flags=-aQg spot_5300-09-03
resetting a SPOT (if an operation failed, with this the resource state (Rstate) will be updated, and SPOT is ready to use):
nim -Fo reset spot_5300-09-03
preferable however to run a force check on the SPOT instead:
checking a SPOT (verifies the usability of a SPOT, and rebuild network boot image if necessary and change its state to "ready for use"):
nim -Fo check spot_5300-09-03
checking the contents of the spot (verifies that software was installed successfully on a spot resource):
nim -o lppchk -a show_progress=yes spot_5200_08
Creating a SPOT from an mksysb (created spot can be used only for this mksysb):
smitty nim_mkres -> spot -> enter the values needed (the Source of Install Image should be the mksysb)
checking if a SPOT contains a fileset:
nim -o showres 'spot_5300-11-04_bb1' | grep bos.alt_disk_install.rte
nim -o lslpp -a filesets="bos.alt_disk_install.rte" spot_5300-11-04_bb1
checking if a SPOT contains a specific driver:
e.g. lsdev -Cc adapter displayed this driver "2514310025140100"
nim -o lslpp AIX_6100-06_SPOT |grep 2514310025140100
checking a SPOT level (similar to instfix -i | grep ML):
root@aixnim1: / # nim -o fix_query spot_5200-08 | grep ML
All filesets for 5.2.0.0_AIX_ML were found.
All filesets for 5200-01_AIX_ML were found.
All filesets for 5200-02_AIX_ML were found.
update a spot with an lpp_source:
nim -o cust -a fixes=update_all -a lpp_source=5305_lpp 5305_spot
SPOT is an installed entity, like any other AIX system, so it can run into cases where it has broken filesets, broken links, or missing/corrupt files. They are also fixed in the same manner as you would on any other system:
nim -o lppchk -a lppchk_flags="v" 5305_spot <--use the "Force Overwrite" or "Force Reinstall" options for -v errors
nim -o lppchk -a lppchk_flags="l" 5305_spot <--using the "-ul" flags for missing links from "-l" errors
nim -o lppchk -a lppchk_flags="c" 5305_spot <--replacing bad files for any "-c" output
----------------------------------
Spot creation with SMITTY:
smitty nim -> perform nim administration -> manage resources -> define a resource (spot)
Resource Name [spot_TL7_SP3]
Resource Type spot
Server of Resource [master]
Source of Install Images [TL7_SP3]
Location of Resource [/nim/spots]
...
COMMIT software updates? yes
----------------------------------
Spot update with SMITTY:
(bos.alt_disk_install.rte fileset will be added to a spot)
smitty nim -> perform nim softw. inst. -> inst. and upd. softw. -> Inst. softw. (spot -> lpp_source)
Installation Target spot_TL7_SP3
LPP_SOURCE TL7_SP3
Software to Install [+ 6.1.7.2 Alt. Disk Inst. Runt.] <--after F4 -> bos.alt_disk_install.rte with F7
...
installp Flags
COMMIT software updates? [yes]
SAVE replaced files? [no]
----------------------------------
Creating a SPOT from an mksysb file:
(this SPOT is valid only for that specific LPAR, to do maintenance boot for example)
1. check mksysb level:
# lsmksysb -lf <mksysb file> | grep SERVICEPACK
(outout, likeS SERVICEPACK LEVEL: 7200-03-01-1838)
2. define mksysb resource from mksysb file
# nim -o define -t mksysb -a server=master -a location=<path to mksysb file> <mksysb resoruce name>
3. define spot from mksysb resource:
# nim -o define -t spot -a server=master -a source=<mksysb resource> -a location=<where to create the spot resource> <spot name>
----------------------------------
20 comments:
very nice info.. short and sweet...
I worked a lot on this page, to remain brief and clear...I'm really happy that you like it :)
tnx for the blog however is there a way to create a spot so that it can be used by other clients besides the client that was used for the spot creation ie can host2 use the same spot as host1 for a mksysb restore if they are on the same OS level
Yes, absolutely. If you have a SPOT, every NIM client can use it, which is on the same OS level as the SPOT.
(by the way I create SPOTs from an install resources, not from hosts.)
Hello...Is there a way to remove a fileset from a spot please let us know the command
Hi, I wanted to do the same few weeks ago, but I did not find a command for this, so I recreated the spot. Probably someone out there knows how to do that.
Hi! During creation of SPOT in smitty nim, is there a way to know what is already the percentage/status being created? Thank you.
I don't know any of that...probably someone else.
I need ur Help .....I m creating nim spot resource but I m getting below error.....Pls help me
# lsnim -l 710spot _res
710spot_res:
class = resources
type = spot
arch = power
bos_license = yes
Rstate = information is missing from this object's definition
prev_state = verification is being performed
info = warning: 0042-157 c_ckspot: unable to access the "/export/nim/spot/710spot_res/usr/./lpp/bosinst/image.template" file
location = /export/nim/spot/710spot_res/usr
version = 7
release = 1
mod = 2
oslevel_r = 7100-02
alloc_count = 0
server = master
Rstate_result = success
mk_netboot = yes
missing = "network boot image"
missing = bos.64bit
missing = bos.diag
missing = bos.mp64
missing = bos.net.nfs.client
missing = bos.net.tcp.client
missing = bos.net.tcp.smit
missing = bos.sysmgt.nim.client
missing = bos.sysmgt.nim.spot
missing = bos.sysmgt.serv_aid
missing = bos.sysmgt.smit
missing = bos.sysmgt.sysbr
missing = bos.terminfo
missing = bos.wpars
missing = bos.wpars
missing = mcr.rte
missing = mcr.rte
Spot update with SMITTY:
(if the fileset bos.alt_disk_install.rte is not installed then it should be:
Given line:
smitty nim -> perform nim softw. inst. -> inst. and upd. softw. -> upd. inst. softw. (spot -> lpp_source)
should be:
smitty nim -> perform nim softw. inst. -> inst. and upd. softw. -> Inst. softw. (spot -> lpp_source)
Hi, corrected, thx!
I suggest you also put one:
nim -o deallocate -a subclass=all server-name
Which is handy for people incase they strike with some resource remains locked with nim for some or other reason. It would make sure all resources are deallocated to the specified host from NIM
smitty nim > Perform NIM Administration Tasks > Manage Resources > Perform Operations on Resources > [choose the SPOT] > maint = perform software maintenance >
Perform SPOT installp Maintenance
Type or select values in entry fields.
Press Enter AFTER making all desired changes.
[Entry Fields]
* Resource Name spot-vio2223
* installp Flags [u]
Fileset Names [EMC.Symmetrix.ha.rte]
installp Bundle [] +
Force no +
Hope this helps someone.
HI Belaz , Can you help clue me in something? Here is what I did , I downloaded iso image for AIX 7 from ibm site, then I use loopmount command to create iso (dvd1 and dvd2) and then I used smitty bffcreate to put all the filesets in one directory (both dvd1 and dvd2) , after that I created lpp_source from that , but I can't create the spot from that lpp_source , nor can I upgrade any previous spot , this is the error I get when i try to create spot from that lpp_source : 0042-162 m_mkspot: an lpp_source which has the "simages"
attribute is required for this operation
HI Belaz , never mind following my problem, I was trying to get away with not upgrading NIM, but apparently, we can't. I knew it from the beginning but still wanted to take a chance.
NIM 0042-267 Problem :
warning: 0042-267 c_mk_lpp_source: The defined lpp_source does not have the
"simages" attribute because one or more of the following
packages are missing:
ifor_ls.base
lum.base
Solution :
It could be that your NIM master is at a lower level than the lpp_source and could not account for the two filesets: ifor_ls.base and lum.base.
After all this I just have one last question, Its very obvious that I need to upgrade NIM server first, This nim server is used for many other things, I am thinking about building another nim server in the same P7 to do all my nimadm migration, Anyone has more than one NIM server in same machine, is there anything I should be cautious about ?? Thanks !!
Hi, I have used smitty nim to create spot and mksysb's... but couldn’t create it for my NIM master server..
I figured out to make mksysb of NIM master using smitty mksysb.
I can’t figure out how to make spot for my mksysb..
I’ve also tried this command:
nim -o define -t spot -a server=master -a location=/export/spot/7134_gold_spot_z06 -a source=7134_gold_mksysb_z06 7134_gold_spot_z06
am getting this error for boy above command and smitty nim
0042-001 nim: processing error encountered on "master":
0042-055 m_mkspot: "7134_gold_mksysb_z06" is not a valid "source" for
this operation
Any help is appreciated.
im getting an error while creating the SPOT
0042-001 nim: processing error encountered on "master":
0042-103 m_mkspot: unable to restore from backup_135
can any one help!!
thanks in advance
Dear Supporting Friends
I have a nim server oslevel 6.1 tl 9. I have a mksysb image on it of aix5.3 for 1 of my server
I want to use that mksysb of 5.3 on a blank server using nim server with os 6.1 tl9. In this case i am getting error saying "....the level of SPOT used for the installation must match the level of the mksysb image that is being installed. The release level of the SPOT, 610spot_res, and the mksysb, , do not match.
Can i make a new spot on same 6.1 but for 5.3 ? Will it any way affect the existing OS of my Nim Master ???
Thanks it works
Post a Comment