dropdown menu

STORAGE - BASICS

Basics - Settings

lsdev -Cc disk             shows what kind of disks we have: SCSI, SSA, ESS, HITACHI, Virtual disks                   

hdisk0  Available 40-60-00-4,0 16 Bit LVD SCSI Disk Drive                  <-SCSI
hdisk2  Available 30-68-L      SSA Logical Disk Drive                      <-SSA
hdisk0  Available 01-08-00      SAS Disk Drive                             <-SAS

hdisk9  Available 2D-08-01     IBM FC 2105                                 <-ESS
vpath0  Available              Data Path Optimizer Pseudo Device Driver    <-ESS

hdisk2  Available 1n-08-02     Hitachi Disk Array (Fibre)                  <-HITACHI
dlmfdrv0 Available             HDLM Driver                                 <-HITACHI

hdisk6  Available 03-00-01      EMC CLARiiON FCP RAID 1/0 Disk             <-EMC

hdisk2  Available 07-08-02     HP HSV210 Enterprise Virtual Array          <-HP EVA

hdisk0  Available           Virtual SCSI Disk Drive                        <-VIRTUAL DISK




bootinfo -s    hdisk5        shows the size of the disk
lscfg -vl hdisk0             displays configuration, diagnostic, and vital product data
lsattr -El hdisk6            shows attributes of hdisk6. If MPIO disk you can change these values with:

mkdev -c disk -t 1200mb -s scsi -p scsi0 -w 6,0 -d creates a dummy hdisk (if it is needed to correct the sequence numbers)
mkdev -l hdiskX -p dummy -c disk -t hdisk -w 0000  the same as above (for me gave error, but created it)


root@aix31:/ # lsattr -El hdisk6
PCM             PCM/friend/sddpcm                PCM                                     True
PR_key_value    none                             Reserve Key                             True    <-PR_key value
algorithm       load_balance                     Algorithm                               True    <-path selection algorithm (round robin...)
clr_q           no                               Device CLEARS its Queue on error        True
dist_err_pcnt   0                                Distributed Error Percentage            True
dist_tw_width   50                               Distributed Error Sample Time           True
hcheck_interval 60                               Health Check Interval                   True    <-how often the paths should be health-checked
hcheck_mode     nonactive                        Health Check Mode                       True    <-health check
location                                         Location Label                          True
lun_id          0x5105000000000000               Logical Unit Number ID                  False
lun_reset_spt   yes                              Support SCSI LUN reset                  True
max_transfer    0x40000                          Maximum TRANSFER Size                   True
node_name       0x5005076300c0a1df               FC Node Name                            False
pvid            005dd06a948b72f50000000000000000 Physical volume identifier              False
q_err           yes                              Use QERR bit                            True
q_type          simple                           Queuing TYPE                            True
qfull_dly       20                               delay in seconds for SCSI TASK SET FULL True
queue_depth     20                               Queue DEPTH                             True
reserve_policy  no_reserve                       Reserve Policy                          True    <-reserve policy (PR_reserved...)
rw_timeout      60                               READ/WRITE time out value               True
scbsy_dly       20                               delay in seconds for SCSI BUSY          True
scsi_id         0xc0b00                          SCSI ID                                 False
start_timeout   180                              START unit time out value               True
unique_id       1D081052567107210580003IBMfcp    Device Unique Identification            False
ww_name         0x5005076300cca1df               FC World Wide Name                      False

algorithm:
pcmpath set device algorithm or chdev -l hdiskX -a algorithm=round_robin

reserve_policy:
chdev -l hdiskX -a reserve_policy=no_reserve
no_reserve: Input/Output can be sent from all the pahts of the MPIO device. This is the default for SDDPCM
        For HDLM: Ignores a reservation and does not reserve a LUN (for VIO and RAC this is needed)

exclusive host access: only 1 path can be selected with fail_over. When the active path fails, thealternative path is selected
        PR_exclusive: a uniques PR_key is set for this host. Other hosts with different PR_key cannot access.
        I/O is routed to all path of the MPIO device, because all paths are registered with the same PR_key.
        In a non-concurrent HACMP environment this should be selected.

PR_shared:
A PR_key is registered, but it can be accessed by other hosts.
        In a concurrent HACMP environment this should be used.
        (chdev -l hdiskX -a PR_key_value=0x1234 -a reserve_policy=PR_shared)

The default attribute of reserve_policy of the hdlm driver is PR_exclusive. This is set automatically during cfgmgr to the ODM. Because of the virtualisation requirements, we have to change it to “no_reserve”. So the chdev command sets a SCSI reservation(PR_exclusive) to change the attribute. All LPARs, which are writing exact at this moment to this disk will receive not-recoverable errors (The virtualisation disk outage from 22.10.2009).


hcheck_mode:
pcmpath set device hc_mode or chdev -l hdiskX -a hc_mode=failed
enabled: health checking paths that are opened
failed: health checking path that are in failed state
nonactive: this is the default, will check paths that have non active I/O (this includes paths that are opened or in failed state)

hcheck_interval:
pcmpath set device hc_interval or chdev -l hdiskX -a hc_interval=0
0: health check function is disabled
60: it is the default (max: 3600)

This is the SDDPCM internal health check, but SDDPCM server daemon does healthchecking as well. The SDDPCM server daemon only health check FAILED paths. It does not implement healthcheck on opened or idle paths as the SDDPCM internal healthcheck does.

queue_depth:
it is the number I/O requests each device can handle concurrently
In case of a Hitachi disk (HDLM), recommendation is to set this value greater than or equal to the number of the paths.


RAID LEVELS:


RAID 0+1 
    Fault tolerance with fast write performance
RAID 0        Fast writes
RAID 5        Fault tolerance

10 comments:

Raja K said...
This comment has been removed by a blog administrator.
Anonymous said...

Hi,

What is a RAID controller in P-Series. Is there any difference between the normal raid controller and this. I was told that only one LPAR can be created on a server with 4 HDD's and a single RAID controller. Please enlighten us.

Regards
Kums

aix said...

Hi, I'll look after that, but meanwhile I suggest read the System Documentation of your server, for more info about RAID controller.

Regards,
Balazs

Siva said...

Hi,

Could pls explain bit more advantages of queue_depth.

Regards,
Siva

aix said...

Hi,
Here is the full description: http://www-03.ibm.com/support/techdocs/atsmastr.nsf/WebIndex/TD105745
I know it is a bit long :)

Anonymous said...

my question is regarding AIX 6.1.3- does anybody has a sequential procedure (meaning 1,2,3) oh how to add 10G to an lv that as example is mounted on /data/oracle - This lv is running out of pv (hdisks) but the volume group shows that has still 24.5 GB (49 PPs that are 512 in size each )- I have an hdisk2 available to add to my lv -cz this vg has already use hdisk0 & hdisk1, but I have hdisk2 available however it has not been added to the vg yet-and I need to add 10GB to the lv - somebody told me to use ;
# chfs -a size=+10G /oracle/product but I'm doubtful if I enlarge the fs and I don't have a pv (hdisk2) added to the lv how can I change the fs or does the chfs takes care of that in the background -I will like to see if somebody can tell the 1,2,3 procedure from the command line and from the smitty menu -Thanks

Anonymous said...

hi I am updating SAN storage firmaware , Can anyone tell me , after & before updating SAn waht are the cheks rewuired at aix server - thanks in advance

Anonymous said...

Similar to "reserver_lock" attribute for the EMC LUN, do we have same setting for iSCSI disk ., like assign form dual VIOS..?

Anonymous said...

In AIX 7.1/7.2 are parameters like qfull_dlly or scbsy_dly configurable? I don't see these parameters any more when I use "lsattr -El hdsik4". Any suggestions?

Saurabh Sharma said...

Hi Team ,

How to make lun and add in vg process step . Please reply me